Icon

Vim v9.0-6

Vim is a highly configurable text editor built to enable efficient text editing. It is an improved version of the vi editor distributed with most UNIX systems. NOTE: This package is built without Python support.

Version 9.0-6
1. Update vim to v9.0
2. Remove python support
Date
2023-09-10 21:23:21.088613
Architectures
DSM 6.x: 6.2 88f628x 6.2 alpine 6.2 alpine4k 6.2 armada370 6.2 armada375 6.2 armada38x 6.2 armadaxp 6.2 comcerto2k 6.2 monaco 6.2 apollolake 6.2 avoton 6.2 braswell 6.2 broadwell 6.2 broadwellnk 6.2 broadwellntbap 6.2 bromolow 6.2 cedarview 6.2 denverton 6.2 dockerx64 6.2 geminilake 6.2 grantley 6.2 kvmx64 6.2 purley 6.2 v1000 6.2 x86 6.2 x86_64 6.2 armada37xx 6.2 rtd1296 6.2 evansport 6.2 hi3535 6.2 qoriq
DSM 7.x: 7.1 alpine 7.1 alpine4k 7.1 armada370 7.1 armada375 7.1 armada38x 7.1 armadaxp 7.1 monaco 7.1 apollolake 7.1 avoton 7.1 braswell 7.1 broadwell 7.1 broadwellnk 7.1 broadwellnkv2 7.1 broadwellntbap 7.1 bromolow 7.1 cedarview 7.1 denverton 7.1 epyc7002 7.1 geminilake 7.1 grantley 7.1 kvmx64 7.1 purley 7.1 r1000 7.1 v1000 7.1 armada37xx 7.1 rtd1296 7.1 rtd1619b 7.1 comcerto2k 7.1 evansport
Version 9.0-5
Update vim to v9.0.
Date
2023-01-27 05:37:45.988362
Architectures
DSM 6.x: 6.1 88f628x 6.1 alpine 6.1 alpine4k 6.1 armada370 6.1 armada375 6.1 armada38x 6.1 armadaxp 6.1 comcerto2k 6.1 monaco 6.1 apollolake 6.1 avoton 6.1 braswell 6.1 broadwell 6.1 broadwellnk 6.1 broadwellntbap 6.1 bromolow 6.1 cedarview 6.1 denverton 6.1 dockerx64 6.1 geminilake 6.1 grantley 6.1 kvmx64 6.1 purley 6.1 v1000 6.1 x86 6.1 x86_64 6.1 armada37xx 6.1 rtd1296 6.1 evansport 6.1 hi3535 6.1 qoriq
DSM 5.x: 5.2 88f628x 5.2 ppc853x 5.2 x86
DSM 7.x: 7.1 alpine 7.1 alpine4k 7.1 armada370 7.1 armada375 7.1 armada38x 7.1 armadaxp 7.1 monaco 7.1 apollolake 7.1 avoton 7.1 braswell 7.1 broadwell 7.1 broadwellnk 7.1 broadwellnkv2 7.1 broadwellntbap 7.1 bromolow 7.1 cedarview 7.1 denverton 7.1 epyc7002 7.1 geminilake 7.1 grantley 7.1 kvmx64 7.1 purley 7.1 r1000 7.1 v1000 7.1 armada37xx 7.1 rtd1296 7.1 rtd1619b 7.1 comcerto2k 7.1 evansport
SRM 1.x: 1.2 dakota 1.2 ipq806x 1.2 northstarplus
Version 8.2-4
1. You now need Python 3.8 to enable Python support.
2. utf-8 wrapper removed.
Date
2021-11-03 22:20:01.446354
Architectures
DSM 6.x: 6.1 aarch64 6.1 armada37xx 6.1 rtd1296 6.1 alpine 6.1 alpine4k 6.1 armada370 6.1 armada375 6.1 armada38x 6.1 armadaxp 6.1 comcerto2k 6.1 monaco 6.1 apollolake 6.1 avoton 6.1 braswell 6.1 broadwell 6.1 broadwellnk 6.1 bromolow 6.1 cedarview 6.1 denverton 6.1 dockerx64 6.1 geminilake 6.1 grantley 6.1 kvmx64 6.1 purley 6.1 v1000 6.1 x86 6.1 x86_64 6.1 evansport 6.1 hi3535 6.1 qoriq
DSM 7.x: 7.0 aarch64 7.0 armada37xx 7.0 rtd1296 7.0 alpine 7.0 alpine4k 7.0 armada370 7.0 armada375 7.0 armada38x 7.0 armadaxp 7.0 monaco 7.0 apollolake 7.0 avoton 7.0 braswell 7.0 broadwell 7.0 broadwellnk 7.0 bromolow 7.0 cedarview 7.0 denverton 7.0 dockerx64 7.0 geminilake 7.0 grantley 7.0 kvmx64 7.0 purley 7.0 v1000 7.0 x86 7.0 x86_64 7.0 comcerto2k 7.0 evansport
SRM 1.x: 1.2 dakota 1.2 ipq806x 1.2 northstarplus
Version 8.2-3
1. Update to vim 8.2
2. Enable Python 3 support if Python >= 3.6.1 is installed.
Date
2020-11-06 23:36:00.604805
Architectures
DSM 6.x: 6.1 88f628x 6.1 aarch64 6.1 armada37xx 6.1 rtd1296 6.1 alpine 6.1 alpine4k 6.1 armada370 6.1 armada375 6.1 armada38x 6.1 armadaxp 6.1 comcerto2k 6.1 monaco 6.1 apollolake 6.1 avoton 6.1 braswell 6.1 broadwell 6.1 broadwellnk 6.1 bromolow 6.1 cedarview 6.1 denverton 6.1 dockerx64 6.1 geminilake 6.1 grantley 6.1 kvmx64 6.1 purley 6.1 v1000 6.1 x86 6.1 x86_64 6.1 evansport 6.1 hi3535 6.1 qoriq
SRM 1.x: 1.2 dakota 1.2 ipq806x 1.2 northstarplus
DSM 5.x: 5.2 ppc853x
Version 7.4-2
1. Support UTF8 by default
Date
2015-01-28 22:46:07.812986
Architectures
DSM 3.x: 3.1 88f628x 3.1 armada370 3.1 armadaxp 3.1 bromolow 3.1 cedarview 3.1 comcerto2k 3.1 evansport 3.1 ppc824x 3.1 ppc853x 3.1 ppc854x 3.1 qoriq 3.1 x86
DSM 5.x: 5.1 alpine 5.1 alpine4k 5.1 armada375 5.2 armada38x 5.0 avoton 5.2 braswell 5.2 monaco